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Working with Text
Text plays a central part in nearly all documents and publications. For centuries
the written word has been the bearer of information of all types. To create text
safely and quickly and to select and edit it, the program offers you a huge array
of commands, which may already be familiar to you from word-processing
software.

Creating Text objects
VivaDesigner is an object oriented typesetting and layout program. This means all text in this
program is processed using text frames or text objects. You need to create text objects before
you can enter or modify text. Text is composed and modified within an object, and the object‘s
outer measurements determine the frame of the text.
Text objects in the application may have any form as long as they are closed. A new text object
is created by means of the closed object tools in the Toolbar.
The program offers you several ways to create Text objects:
Create a new text object interactively
1. Choose one of the following options:
- Click in the Toolbar on the Text object tool to choose the default or last text object tool
selected.
- Click the arrow on the right hand side of the tool and choose a tool in the upper section
(Type 1) to create a text object with the text running from left to right.
- Click the arrow on the right hand side of the tool and choose a tool in the middle section
(Type 2) to create a text object with the text running from right to left (e.g. for Arabic,
Hebrew, etc.).
- Click the arrow on the right hand side of the tool and choose a tool in the lower section
(Type 3) to create a text object with the text running from top to bottom (e.g. for Chinese,
etc.).
2. Click on the document page and create your Text object.
It may be quicker for you to create your Text object using the menu or shortcut keys:
Create a new Text object with Menu/shortcut keys:
1. Choose one of the following options:
- Press the shortcut keys Ctrl + Shift + T (Windows/Linux) or Command + Shift + T (Mac).
- Select the menu command Object >Content > Text.
You can also create a Text object by converting another closed object into a Text object.
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If you change a graphic object into a text object the conversion will be immediate. However if a
picture object is changed into a text object an alert message may appear warning you that the
picture’s content will be lost.
Convert an existing object into a Text object:
1. Choose an existing closed object.
2. Choose one of the following options
- Press the shortcut keys Ctrl + Shift + T (Windows/Linux) or Command + Shift + T (Mac).
- Choose the menu command Object >Content > Text.
- Choose the command Content > Text in the context menu.
Editable Text obects can also be created be creating an Alias text object with variable content
or by converting an existing Alias Text object to a copy of the original.
Create a Text object by creating an Alias object with variable content:
1. Create a Text object and enter some text in it.
2. Choose an appropriate option to activate the Object mode:
- Click on the object frame.
- Click anywhere in the text while holding down the Ctrl key (Windows/Linux) or the
Command key (Mac).
- Move the mouse over the middle of the object until the gray Object Mode Select button
appears and click once.
3. Choose one of the following options to open the Special Settings dialog:
- Press the shortcut keys Ctrl + Alt + M (Windows/Linux) or Command + Option + M (Mac).
- Choose the menu command Object > Special.
- With the right mouse button held down, choose the command Special in the Context menu.
4. Choose the option Individual Alias Content and confirm with OK.
5. Choose an appropriate option to create an Alias object from the Text object:
- Press the shortcut keys Ctrl + x (Multiplication) or Ctrl + Shift + * (Windows/Linux), or
Command + * (Mac).
- - Select the menu command Object > Alias > Create Alias.
Now you can write a different text in the Alias Object. The object attributes (Fill Color/Shade,
Frame Color/Shade/Style) are determined by those of the original object.
If you now select the object and choose the menu command Object > Alias > Change into a Copy,
the Alias object will be converted to an independent copy of the original. Both the content and
the graphic attributes can then be edited at will.
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Summary Creating Text Objects
- Text objects can be created by using the Toolbar.
- Text objects can be created automatically using the shortcut keys Ctrl + Shift + T (Windows/
Linux) or Command + Shift + T (Mac), or with the menu command Object > Content > Text,
providing no other object is selected.
- Text objects can be created by converting other object types.
- Modifiable text objects can also be created by converting Alias text objects into copies of
the original.

Text mode
Activate/leave Text mode
To enter or import text into a text object you will need to enable the text mode. As you already
know the mouse pointer will automatically change into the appropriate pointer for the specific
object type.
When the mouse pointer is positioned over a text object it will change into an I-beam (text)
pointer.
Activate Text mode:
Click the mouse on the surface of the Text object.
After the text mode is selected by clicking on the object,
- the Text menu will appear.
- the Module palette (in Text mode) will appear, providing the palette has not been closed.
- the object frame will be highlighted. This imaginary frame shows where the mouse
pointer will change into the object pointer with which you can select and move the
object itself.
- hollow handles will appear. These handles show that you are in Text mode and indicate
where the mouse pointer will change into the sizing pointer with which the object can be
resized.
To activate Text mode in a text object which is part of a group of objects, the Group Mode must
be deactivated, if you do not want to Ungroup the objects.
Activate Text mode in object groups:
1. Choose one of the following options to deactivate the Group mode:
- Press the shortcut keys Ctrl + Alt + U (Windows/Linux) or Command + Option + U (Mac).
- Choose the menu command Object > Group mode Active.
2. Click with the mouse pointer on the text object as previously described.
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You can leave the Text mode by selecting another object, selecting no object or by selecting
the current Text object.
Leave Text mode:
Choose one of the following options to leave Text mode:
- Click anywhere in the document window where there is no object positioned.
- Change to Object mode by holding down the Ctrl key (Windows/Linux) or the Command
key (Mac), and click the current Text object or another object.
- Click with the mouse pointer on a sizing handle of the current Text object and hold down
the mouse button to resize the object. The program changes to Object mode automatically.
- Move the mouse over the middle of the object until the gray Object Mode Select button
appears and click once. If the button does not appear, the object height or width is too
small and you must choose another option.

Summary Activate/Leave Text mode
If Text mode is enabled the program will display the following:
- The blinking insertion point or cursor in the text.
- A highlighted frame for all objects that are part of the current linked text chain, whether
the command Show Guides is activated in the View menu or not.
- The Text menu.
- The Module palette (Text mode), if the palette was not specifically hidden.
- Hollow handles, if the object is an original object, and not a Flexible Alias Text object.

Entering text
Entering and correcting text
To define the appearance of a text you have two possibilities. First of all settings may be made
in dialogs and palettes, which will take effect for all text entered after the current cursor position.
Secondly, settings and modifications may be made to existing text passages if these have not
previously been marked.

The insertion point (cursor)
To edit a specific piece of text, move the insertion point to the text either using the arrow keys
or by clicking the mouse pointer at the specific location. Once you have clicked the pointer will
change from the I-beam pointer into a blinking insertion point.
If you click the margin between the object frame and the text VivaDesigner will position the
insertion point at the location closest to that point.
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If the insertion point is positioned in an empty text object it will automatically appear in the
upper left corner of the object. Positioning the insertion point on a page of the document
where as yet no text has been entered will cause it to spring back to the end of the entered text
automatically.
The application also allows you to position the insertion point using keyboard commands.

Summary cursor
Move to

Shortcut

Next character

Arrow-right

Previous character

Arrow-left

Next line

Arrow-down

Previous line

Arrow-up

Next word

Ctrl + Arrow-right (Window/Linux),
Command + Arrow-right (Mac)

Previous word

Ctrl + Arrow-left (Window/Linux),
Command + Arrow-left (Mac)

Next paragraph

Ctrl + Arrow-down (Window/Linux),
Command + Arrow-down (Mac)

Previous paragraph

Ctrl + Arrow-up (Window/Linux),
Command + Arrow-up (Mac)

End of line

Ctrl + Alt + Arrow-right (Window/Linux),
Command + Option + Arrow-right (Mac)

Beginning of line

Ctrl + Alt + Arrow-left (Window/Linux),
Command + Option + Arrow-left (Mac)

Entering functions
As well as Text with a fixed length, the program enables you to insert functions that possess a
variable length. In total of nine functions are available in the Menu section Insert function.
To insert a function in the text, position the cursor in the Text object. Select any function from
the Text menu that you want to insert into your text automatically. It may occur with page
commands that instead of a character a space is entered. This happens when the function
selected has an invalid value or parameter. If for example on the first and only page of a document the function Last Page Number or Continued from is inserted, the function will be
replaced by a space.
Enter a function:
1. Set the cursor at the required position.
2. Select a function from the Text menu OR the Context menu:
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- Choose Insert Hyphens and Dashes and select an option from the popup menu.
- Choose Insert Line Breaks and select an option from the popup menu.
- Choose Insert Variable and select an option from the popup menu.
- Choose Object and select an option from the popup menu to insert a floating object.
Note:
The object types available for import depend on your license.
If you import a picture object, the object will be sized according to the width of the text
object. You can edit the size and content of the object at any time after importing.
If the image you want to import is large, it may be that you will see a text overflow in the
bottom right hand corner of the text object. If this should occur, cancel the floating object
import, create a picture object with its content outside the text object, and edit its size and
content accordingly. Then cut the object and paste it into the text at the required position.

Importing text
As well as the possibility of entering or pasting text, the application allows the import of text
files, which may be available in various formats.
Import with the Import command:
1. Place the insertion point in the Text object.
2. Choose an appropriate option:
- Press the shortcut keys Ctrl + E (Windows/Linux) or Command + E (Mac).
- Choose the menu command File > Import.
3. Choose a *.txt or an *.rtf file from the dialog.
4. Click the Open button.
Note:
When you import *.txt files, the program will open the dialog Select Text Encoding. In this
dialog you can choose the encoding for the text file you want to import.
When you import *.rtf files whose text has various attributes, then these too will be imported
as far as is possible.

Selecting text
Selecting text passages
In order to apply a command to a text block, you need first to define the text block to which
the command should be applied.
Similar to the positioning of the insertion point, the program offers several keyboard commands to do this. It is of course also possible to select text interactively.
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Single text passages
To select single text passages with the mouse, position the insertion point at the start, or at the
end, of the text you want to select. Hold down the mouse button while you drag the mouse
across the text.
You will be able to see on your monitor that the area selected is marked with the help of the
mouse. Once you have selected the text release the mouse button.
To select text using the keyboard you position the insertion point at the start or at the end of
the text you want to select. Hold down the Shift key and use the arrow keys to mark your text
selection.
The Left and Right arrow keys will select the text in that direction, the Up and Down arrow keys
will select the text at the line above and under the current insertion point.
Mark a text passage with the mouse:
1. Place the insertion point at the required position in the text.
2. Hold down the mouse button and drag the mouse across the text.
Mark a text passage with keyboard commands:
1. Place the insertion point at the required position in the text.
2. Hold down the Shift key and use the arrow keys to select the appropriate text passage.
Mark a text passage with keystrokes:
1. Place the insertion point at the required position in the text.
2. Hold down the Shift key and click at another point in the text.
The text between the insertion point and the position you clicked has now been selected.
If the beginning and end of the text passage you wish to mark are not both visible at the same
time or are on separate pages, marking the text can be tricky . In this case therefore you should
proceed exactly as described above.
Marking across pages:
1. Place the insertion point in the text, either at the beginning or end of the area to be marked.
2. Move to the other end of the area to be marked.
3. Hold down the Shift key and click on the point where the text passage to be marked starts or
finishes.
Here too the text between the insertion point and the point you have defined will be marked.

Selecting text elements
A text object contains different text elements, such as a word, a line and a paragraph.
Select a word interactively with the mouse:
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2. Double-click the word.
The program will recognize a character string delimited by a space character or a punctuation
mark as a word. A soft hyphen will also be considered a punctuation mark as long as it is not
automatically generated by the program.
Select a line interactively with the mouse:
1. Position the I-beam pointer on a line.
2. Triple click the line.
Select a sentence interactively with the mouse:
1. Position the I-beam pointer in a sentence.
2. Click four times to select the sentence.
Select a paragraph interactively with the mouse:
1. Position the I-beam pointer over a paragraph.
2. Click five times to select the whole paragraph.
Precise text selection is also possible using the keyboard.
Choose a word using the keyboard:
1. Position the insertion point at the beginning of the word.
2. Hold down the shortcut keys Ctrl + Shift (Windows/Linux) or Command + Shift (Mac) and
press the arrow-right key.
ATTENTION: This will also select the space character after the word.
Selection of lines or paragraphs using the keyboard will not always result in the selection of the
whole line or the whole paragraph. This depends upon the position of the insertion point.
Choose text passage with the keyboard:
Choose an appropriate option:
- Hold down the Shift key and press the Pos 1 or Home key (Windows/Linux) to select all the
text from before the insertion point to the beginning of the line.
- Press the shortcut keys Command + Option + Shift and press the arrow-left key (Mac) to
select all the text from before the insertion point to the beginning of the line.
- Hold down the Shift key and press the arrow-left key to select single text characters
between the insertion point and the beginning of the line. (Windows/Linux/Mac).
- Hold down the Shift key and press the End key (Windows/Linux) to select all the text from
after the insertion point to the end of the line.
- Press the shortcut keys Command + Option + Shift and press the arrow-right key (Mac) to
select all the text from after the insertion point to the end of the line.
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- Hold down the Shift key and press the arrow-right key to select single text characters
between the insertion point and the end of the line. (Windows/Linux/Mac).
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- Press the shortcut keys Ctrl + Shift (Windows/Linux) or Command + Shift (Mac) and press
the arrow-down key to select all the text from after the insertion point to the end of the
paragraph.
- Hold down the Shift key and press the arrow-down key to select all the text line by line
after the insertion point. (Windows/Linux/Mac). The text will always be selected up to
the horizontal position of the insertion point.
- Press the shortcut keys Ctrl + Shift (Windows/Linux) or Command + Shift (Mac) and press
the arrow-up key to select all the text from before the insertion point to the beginning of
the paragraph.
- Hold down the Shift key and press the arrow-up key to select all the text line by line
before the insertion point. (Windows/Linux/Mac). The text will always be selected up to
the horizontal position of the insertion point.

Select the whole text
The program offers several ways to select all the text in a linked text chain. In the application
you can select text interactively with the mouse, with menu commands or with the keyboard.
Select the whole text with the mouse:
1. Place the insertion point anywhere in the text chain.
2. Choose a suitable option:
- Click the mouse button six times quickly.
- Press the shortcut keys Ctrl + A (Windows/Linux) or Command + A (Mac).
- Choose the menu command Edit > Select All.

Change current text selection
If you need to extend or reduce your current text selection, you don’t have to start again. Hold
down the Shift key and click to change the current selection.
Change text selection:
1. Hold down the Shift key.
2. Position the insertion point at the desired position in the text.
3. Release the mouse button.
The current text selection will now be extended or reduced to the position of the insertion
point. Such a change may mean a reduction or an extension of the area selected.

Deselect a text selection
To deselect a text selection simply click the text once. The current text selection will also be
deselected if you leave the text mode.
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Editing text
Delete and replace text
There are two ways to delete single characters or text blocks.
To delete a single character you can use the Backspace or the Forward Delete key. The Backspace
key deletes the character before the insertion point. The Forward Delete key deletes the character
after the insertion point.
To delete larger text blocks, you mark a text area and use the Backspace key to delete it or select
the appropriate menu command.
Delete previous character:
1. Position the insertion point in the text.
2. Press the Backspace key to delete the character before the insertion point.
Delete next character:
1. Position the insertion point in the text.
2. Press the Forward Delete or Del key to delete the character after the insertion point
Delete text passages:
1. Mark/Select a text passage.
2. Choose an appropriate option to delete the selected passage:
- Press the Backspace key or the Forward Delete or Del key.
- Choose the menu command Edit > Delete.
You can also delete text by replacing it. First select the text you want to replace and enter a
new text or use the Paste command in the Edit menu to replace the selected text by the contents of the Clipboard.
Deleting and replacing text selections:
1. Mark/Select a text passage.
2. Choose the menu command Edit > Paste to replace the text with the contents of the Clipboard.

Cut text
Another way to delete text is by cutting it using the Cut command. If a text selection is cut, the
text will be removed from the document and copied to the Clipboard. The difference between
deleting and cutting is that cut text can be pasted back into any point in the document, so
long as no ther text has been cut or copied.
Cut text:
1. Place the insertion point in the text and select a text passage.
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- Press the shortcut keys Ctrl + X (Windows/Linux) or Command + X (Mac).
- Choose the menu command Edit > Cut.
- Choose the command Cut in the Context menu.
When text is cut and thus copied to the Clipboard, all text properties will be copied as well.
This means that properties like font size, style and color as well as Text Style Sheets will all be
stored. When pasting the text back into the document or into another document the text you
paste will look exactly like the text you cut. The only situation in which this cannot be guaranteed is when the names of Colors and Style Sheets are identical but the underlying definitions
have been modified.

Copy text
Apart from deleting and cutting text, text can also be copied. This operation is very similar to
the Cut command. As with cutting text, the text will be copied to the Clipboard but it will not
be removed from the document.
Copy text:
1. Place the insertion point in the text and select a text passage.
2. Choose an appropriate option:
- Press the shortcut keys Ctrl + C (Windows/Linux) or Command + C (Mac).
- Choose the menu command Edit > Copy.
- Choose the command Copy in the Context menu.

Paste text
The commands Cut and Copy are only useful if you need to reuse the text somewhere else in
your documents. Cut or copied text passages may be pasted back into your document anywhere.
Paste text:
1. Copy some text.
2. Position the insertion point at any position in the text.
3. Choose an appropriate option:
- Press the shortcut keys Ctrl + V (Windows/Linux) or Command + V (Mac).
- Choose the menu command Edit > Paste.
- Choose the command Paste in the Context menu.
4. Repeat the instructions from the previous example, but now use the Cut command instead
of the Copy command.
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Note:
When text is pasted all text properties will be stored. This means that properties like font
size, style and color will be identical to the text which was cut or copied. The only situation
in which this cannot be guaranteed is when the color and style names are identical but the
underlying definitions have been modified.

Exporting text
As well as importing text, the text in the current text chain may also be exported as a text file
which may be edited in other programs. This export is a pure ASCII-Format. This means that the
exported text has no attributes. After selecting the command Export > As a Text file In the File
menu the dialog for saving documents will be displayed.
Export Text:
1. Place the insertion point in the Text object.
2. Choose the menu command File > Export > As a Text file.
3. Enter a file name for the text chain to be exported.
4. Close the dialog by clicking the Save button.
5. If necessary enter an Encoding type.
6. Click OK to close the dialog.

Managing attributes
In the following paragraphs we will describe special text properties such as language, font size,
alignment and line spacing can be assigned to the text.
The application has two different ways of handling the modification of these properties: They
are either automatically applied to the current selection or they will be applied to all text after
the insertion point.
If an attribute is set when no text is marked, the new settings for the text will only affect the
text that is entered to the right of the insertion point.

Tabs
Tabs are used to align text at specific horizontal intervals. Tabs are often used to create tables.
A tab stop indicates an exact position in the document at which characters are aligned. Viva
uses four different types of tabs : left, center, right and decimal tabs.
To define the position and type of tab stops, choose the menu command Text > Tabs.
After a left tab stop the text will (still) flow from left to right.
A right tab stop will align the text to the left of the tab stop until it reaches the position of the
tab stop.
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A special case of a right tab stop is the decimal tab stop. The text will align to the left of the tab
stop until it reaches the position of a decimal character. A decimal character can be a comma
or a point. For this reason the decimal tab is most often used in price lists.
The center tab stop will align the text around the tab stop.

Search and Replace
A basic function in any word processor or layout program is a powerful Search and Replace
command. The application allows you to search for characters, invisibles or text properties
which can then be replaced by other characters, invisibles and text properties.
Search and Replace a character string:
1. Position the insertion point at the start of the text in the text object.
2. Choose an appropriate option:
- Press the shortcut keys Ctrl + F (Windows/Linux) or Command + F (Mac).
- Choose the menu command Edit > Search & Replace.
3. Choose the option Search and enter a character string in the entry field.
4. Click on the option Replace and enter another character string in the entry field.
5. Click the Search button.
6. Now click the button Replace & Search to check every single string found before replacing,
or click the button Replace All to make the changes without query.
Search and Replace invisibles:
1. Position the insertion point at the start of the text in the text object.
2. Choose an appropriate option:
- Press the shortcut keys Ctrl + F (Windows/Linux) or Command + F (Mac).
- Choose the menu command Edit > Search & Replace.
3. Choose the option Search and click the Invisibles icon on the right of the entry field.
4. Choose an option from the popup menu.
5. Choose the option Replace and click the Invisibles icon on the right of the entry field.
6. Choose an option from the popup menu.
7. Click the Search button.
8. Now click the button Replace & Search to check every single string found before replacing,
or click the button Replace All to make the changes without query.
Now we will search for a character string in the document that is to be assigned with a different
color.
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Search and Replace attributes:
1. Position the insertion point at the start of the text in the text object.
2. Choose an appropriate option:
- Press the shortcut keys Ctrl + F (Windows/Linux) or Command + F (Mac).
- Choose the menu command Edit > Search & Replace.
3. Choose the option Search. Click the popup menu (default: Text)and select an attribute.
4. Choose the option Replace. Click the popup menu (default: Text)and select an attribute.
5. Now click the button Replace & Search to check every single string found before replacing,
or click the button Replace All to make the changes without query.
TIP:
If in the document there are Text objects not linked to the text chain, the option Document in
the sector Direction & Area should be selected to check all character strings.
Use the arrow buttons underneath the entry fields in both sectors to search for or replace
with a combination of your choice, such as Text XYZ, Font Arial Bold, Size 12 pt and Color
[Magenta], replace with Style Sheet [Body Text].
Use the options in the Case sector to define your needs more exactly.

Index and Tables
The application has different internal memories for managing the index and tables. There are
altogether six different lists with the names Index, Contents Entry, Bibliography Entry, Abbreviation, Picture Entry and Chapter. The naming of these indexes is for your convenience only,
since technically you could generate a Table of Pictures for all bibliography entries or for
example for a list of authors.
The index generation facilities make the compilation of indexes a lot easier. The automatic
generation of an index allows for an up-to-date index with a high degree of accuracy.
An index may contain any character strings of up to 256 characters in length. A string containing a carriage return will only be indexed up to the carriage return.
Create an index entry for a text string:
1. Position the insertion point in the Text object.
2. Mark some text.
3. Choose the menu command Text > Mark as > Index Entry.
4. Repeat the last two steps for every section of text that you wish to include in the index.
To check the index an index must first be created.
Generate an index:
1. Position the insertion point in an empty Text object.
2. Choose the menu command Text > Create > Index.
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Language, Spelling and Hyphenation
The application offers extensive functions to manage text in different languages in one document. Depending which version is supplied, the program
is supplied with different modules for hyphenation and spell-checking.
Depending on the program version and the available modules, you can assign
different languages to text passages, carry out language-oriented spelling
and grammar checks and define language-dependant hyphenation.
Language
When you launch your program version for the first time, an initial dialog will ask you to
define/confirm the program interface language and the default text language for all new text
objects. Which language will be automatically displayed as the initial default by the program
depends on the language of your operating system.
If for example you have an English operating system, the initial default language will be English, and a German operating system will have German assigned to it. Operating systems whose
language the program cannot recognise will automatically receive the default language English. These intial settings will be stored in the Viva program preferences file on your system.
You can redefine the language assigned to a Text as well as the default language for new text
objects at any time.
Assign a language to a text passage:
1. Mark the text passage or place the insertion point in the text at the point from which the
setting should take effect.
2. Choose the language required:
- Choose the language required in the popup menu Language in the section Font & Language of the Character tab in the Module palette.
- Choose the language required in the Text > Language menu.
- Choose the option None if the text does not correspond to any of the languages offered
by the program or if it simply does not require any language assigned to it. In this way
you will ensure that no hyphenation will take place. Furthermore, your text will not be
affected by the Spell and Grammar Check functions or by the replacement of quotation
marks with typographic quotation marks. This option is also relevant if you are using
symbol fonts where the checking and replacement functions are not needed.
When a language is used in a document for the first time, assigning the language may take a
few seconds. If the language is assigned again, you don’t have to wait – the language will be
assigned immediately.
The assignment of the right language is very important for the correct structuring of the document, as the program defines the Hyphenation and Spell Checking as well as typographic quotation marks according to the languages defined.
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Note:
You can still assign a language to a text or to all new text objects even if you do bot possess
the appropriate dictionaries or Hyphenation modules.
Assign a new language to be applied to all new text objects:
1. Open the Preferences dialog with the menu command Edit > Preferences (Windows/Linux) or
VivaDesigner > Preferences (Mac).
2. Choose the new language from the popup menu Language in the Text section:
- Choose the option None if you work with more than one language in your documents and
want to apply the different languages to the text manually or with the help of Style
Sheets. For more information on this subject please refer to the chapter Working with
Style Sheets.
3. Confirm your settings with OK, and close the program to ensure that the settings are saved
in the preferences file.

Hyphenation
The application offers extensive functions for perfect hyphenation of an excellent quality. Below is a brief description:
- Automatic and manual hyphenation
With automatic hyphenation, the application refers to a hyphenation module and possible user
dictionaries. With manual hyphenation, the user can set both hard and soft hyphens.
- Selection of different modules for automatic hyphenation
As well as the standard modules, that are supplied with different program versions, modules
from other manufacturers may be used for hyphenation.
- Different hyphenation settings for paragraphs or words
You can use the settings for automatic hyphenation on paragraphs or on any character strings.
- Entry and management of hyphenation exceptions
The automatic hyphenation can be extended through user dictionaries if the modules do not
know a word or character string, or give them incorrect hyphenation under certain conditions.
- Language-dependant and global hyphenation
Hyphenation is language-dependant. This also goes for user dictionaries, which may be maintained individually by the user.
- Hyphenations with different quality levels (primarily for German)
Hyphenation may follow in different levels of quality. The quality levels are supported by some
hyphenation and language modules (e. g. German).
- Hyphenation with automatic replacement
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Both the automatic hyphenation and the user dictionaries support the automatic replacement
of character strings in a case of hyphenation. Such replacements are indispensable in certain
languages for a high quality hyphenation.
- Automatic saving of all hyphenations in the document
All hyphenations calculated are saved in the document. Because of this a document may be
passed on, even if the recipient does not posess the appropriate hyphenation modules.

Define Hyphenation Module
Spelling and Hyphenation Checkers for different languages are included according to the program version supplied. If you have installed hyphenation modules from other manufacturers,
these may be selected for every single language in the Preferences.
Choose Hyphenation module:
1. Open the Preferences dialog with the menu command Edit > Preferences (Windows/Linux) or
VivaDesigner > Preferences (Mac).
2. Click the entry Language and select the tab Spelling & Hyphenation.
3. Click the column Hyphenation for the appropriate language and select a module.
- If the column Hyphenation displays no entry, no module is selected or available for this
language.
- If the popup menu in the column Hyphenation displays just one entry, no additional
modules are available for this language.

Automatic Hyphenation Options
With the hyphenation options you determine if and how the automatic hyphenation will
hyphenate a word at the end of a line.
Activate Automatic Hyphenation:
1. Mark a text and choose one of the following options:
- Go to the Hyphenation section in the Paragraph tab of the Module palette.
- Choose the menu command Text > Hyphenation.
2. Choose the option Yes in the popup menu Hyphenation to activate the hyphenation using the
modules and user dictionaries installed. After the option has been activated, further settings
may be made:
- In the entry field Smallest Word, select the minimum number of characters allowed in a
string before a hyphenation. Strings with less characters will be ignored automatically
by the Hyphenation module.
- In the entry field Hyphens in a Row, select the number of lines that may have a hyphen at
the end of a line. If a value of 3 is entered, no hyphenation will occur on the fourth line,
even if a hyphenation is possible.
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- In the entry field Minimum before, select the minimum number of characters for the
beginning of a word before the hyphenation. If a string of 10 characters is hyphenated
after the second, fifth and eighth character, the value 3, will mean that the first hyphenation after the second character will not be made. In this case the first hyphenation will
be after the fifth character.
- - In the entry field Minimum after, select the minimum number of characters for the end
of a word after the hyphenation. If a string of 10 characters is hyphenated after the second, fifth and eighth character, the value 3, will mean that the last hyphenation after the
eighth character will not be made. In this case the hyphenation will be after the fifth
character.
- - In the popup menu Quality, select the option No quality, if all the hyphenations in a
word should be made by the automatic hyphenation.
- - In the popup menu Quality, select the option Only good quality or better, if only the
hyphenations should be made that are of a good or very good quality. If the word has no
quality hyphenation, none will be made.
- - In the popup menu Quality, select the option Only best quality, if only the hyphenations should be made that are of a very good quality. If the word has no quality hyphenation, none will be made.
- - In the popup menu Quality, select the option Best possible quality, if only the hyphenations should be made that are of a good or very good quality. If this quality is not
available for the string, the application will automatically use the option No quality.
Note:
- A character string can only be hyphenated when all conditions are fulfilled.
- The Automatic Hyphenation options may be made for any character strings or whole paragraphs.
- The hyphenation quality settings are made independently of the actual possibilities of the
hyphenation module or the language. This can mean that the hyphenation will be made,
but that the settings for the quality will have no effect (e.g. in Spanish).
Deactivate Automatic Hyphenation:
1. Mark a text and select the menu command Text > Hyphenation.
2. Change the option Hyphenation to No to deactivate the hyphenation. After the option has
been deactivated, the other options in the dialog will be grayed out, but may still contain
settings.

Check Automatic Hyphenation
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If you are not sure if the automatic hyphenation has hyphenated a string correctly, you can
check this using the command Hyphenation Suggestions. Please note that the suggested
hyphenation only shows possible hyphenations and their quality. The suggested hyphenation
does not show how and why a string will be hyphenated in special cases or not. Thus for
example the settings for the selected language, possible left and right indents, Aesthetic Rag
settings and all the settings in the Hyphenation dialog define if and how a string may be
hyphenated at a specific point.
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Show Hyphenation Suggestions:
1. Mark a word and select the menu command Text > Hyphenation Suggestions.
2. The first line shows all the hyphenations that the application has found based on the
hyphenation module(s) and user dictionaries. A single dash between the syllables shows a
hyphenation without qualitative value. Two dashes show a qualitatively good value, three
dashes a high quality hyphenation.
3. The second line shows the selected language. Here you can see at once if the hyphenation is
wrong because the wrong language was assigned to the text.
4. The third line shows the hyphenation module that was selected for this language. If you
have installed hyphenation modules from different manufacturers, you can select these in
the Preferences.

Manage Hyphenation exceptions
If specialized terms or own names are used frequently by the user in his text, it is possible that
the program will not under certain circumstances be able to hyphenate them properly, as these
words are unknown. In such a case, a user dictionary for that language may be created to
which the automatic hyphenation will refer. In a hyphenation case, the application will first
refer to the user dictionary before it refers to the dictionaries and hyphenation algorithms
installed.
Define hyphenation exceptions:
1. Choose the menu command Edit > Preferences (Windows/Linux) or VivaDesigner > Preferences
(Mac).
2. Choose the entry User Dictionaries.
3. Choose the language for which the hyphenation exception should be created.
- Choose the language option Global if the word to be hyphenated appears in every language
and should always be hyphenated in the same way.
- If several hyphenation modules are available for a language, select the module that has
separated the word incorrectly or has not separated it at all.
4. Click in the entry field Word and enter a new character string using all possible hyphenations.
5. Klicken Sie auf das Schaltfeld Neu, um die neue Zeichenfolge in das Benutzerwörterbuch zu
übernehmen.
Define a No Hyphenation:
- If a word should never be hyphenated, enter the string without hyphens in the entry field
Word.
As well as the definition of a hyphenation exception, the user can also influence the quality of
the hyphenation, which is important in some languages. While for example in Spanish there are
no quality differences in hyphenation, German has a whole series of hyphenation qualities. This
is because the German language has a great many words that have been put together from
other words, which may then have hyphenations not only between syllables, but also between
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the original words. Such hyphenations are also called Preferred Hyphenations. The quality of a
hyphenation is defined by the number of dashes entered between two syllables.
Define hyphenation quality:
- In the entry field Word, enter a dash between the syllables to create a possible
hyphenation without any quality.
- In the entry field Word, enter two dashes between the syllables to create a good
hyphenation.
- In the entry field Word, enter three dashes between the syllables to create an excellent
quality hyphenation.

Spell Check
With the Spelling and Grammar Checkers you can check a document for spelling errors and
according to the program module supplied also check for grammatical correctness. To carry
out the Spell and Grammar Checks correctly, it is necessary for the appropriate modules to be
loaded when starting the program.
Depending on the program version supplied, the software comes with a module for Spell Check
and Hyphenation for different languages. If you have installed hyphenation modules from
other manufacturers, these may be selected for every single language in the Preferences.
Define Spell Check Module:
1. Choose the menu command Edit > Preferences (Windows/Linux) or VivaDesigner > Preferences
(Mac).
2. Click the entry Language and select the tab Spell Check & Hyphenation.
3. Click the column Spell Check for the appropriate language and select a module.
- If the column Spell Check displays no entry, no module is selected or available for this
language.
- if the popup menu in the column Spell Check displays just one entry, no other modules
are available for this language.

Manual Spell Check
The program enables a Spell Check of marked text passages, the current text chain or the whole
document. When checking the current text chain, the check is made from the position of the
insertion point to the end of the text. It does not matter if the end of the text is visible in the
screen or not.
Start manual Spell Check:
1. Mark a text passage or place the insertion point at the point in the text from which the Spell
Check should start.
2. Choose the menu command Text > Spell Check.
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3. If the application finds an unknown character sequence, the dialog Spell and Grammar
Check will open. In the upper dialog section, the unknown character sequence will be shown
in red in the context of the current sentence or paragraph.
- If you want to replace the unknown character sequence with one of the suggestions,
double-click the entry in the list.
- Alternatively, select the entry in the list and click the Change button
- lternatively, change the unknown character sequence in the entry field Change to and
click the Change button.
- Click the Change Always button if you assume that the error will occur again.
- Click the Ignore button if the unknown character sequence is correct but you do not want
to take over the unknown character sequence in your dictionary.
- Click the Ignore Always button if you assume that the unknown character sequence will
appear several times in the text.
- Click the Learn button if the unknown character sequence is correct and you want to take
over the character sequence in your personal language dictionary. The new sequence
will be imported into the dictionary displayed in the popup menu Language.
- Alternatively, change the language in the popup menu if the character sequence is
assigned the wrong language. After this it is possible that new suggestions will appear in
the list.

Manual Grammar Check
The application enable a Grammar Check of a selected passage, the current text chain or the
whole document. When checking the current text chain, the check is made from the position of
the insertion point to the end of the text. It does not matter if the end of the text is visible in
the screen or not.
Start Grammar Check:
- Choose the option GrammarCheck if as well as any unknown strings grammar errors
should also be corrected.
As a grammar error, for example, double spaces will be shown as well as incorrect or missing
punctuation. In the upper area of the dialog grammar, mistakes are displayed in green text in
the context of the current sentence or paragraph.

Automatic Spell and Grammar Check
The application enables the Spell and Grammar Checks to run in the background fully automatically. In this instance spelling errors will be displayed with a red wavy underline. Grammatical errors will be displayed with a green wavy underline.
Switch Automatic Spell and Grammar Check on and off:
Do one of the following:
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- Choose the menu command View > Automatic Spell Check to switch the automatic Spell
Check function on or off.
- Choose the menu command View > Automatic Grammar Check to switch the automatic
Grammar Check function on or off.
- Activate or deactivate the two functions in the Text section of the Preferences.
Correcting errors displayed by automatic Spell and Grammar Check:
1. To correct a spelling error, which is displayed with a red wavy underline, place the insertion
point on the unknown character sequence.
2. Press the right mouse button to display the correction suggestions in the Context menu.
3. Do one of the following:
- Choose a suggestion by clicking it with the mouse. The word will be corrected immediately.
- Choose the command Learn if the unknown character sequence is correct and you want
to take over the character sequence in your personal language dictionary. The new
sequence will be imported into the dictionary for the language that has been assigned to
the character sequence.
- Choose the option Language to change the language in the popup menu if the character
sequence is assigned the wrong language. After this it is possible that the character
sequence will remain underlined and that new suggestions will appear in the Context
menu when it is re-opened.
- Choose the option Spell Check«to open the Spell and Grammar Check dialog for manual
control as previously described.
- Choose the option Correction Hint if you are not sure where the problem lies.
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